System requirements

SharePoint Farm Reporter must be installed in the web front-end server or application server in the SharePoint 2016 / 2013 / 2010 / 2007 farm.

SharePoint 2016 farms

Processor

Intel Pentium Processor

Operating System

Windows Server 2012 R2 (or) Windows Server 2016 with .NET Framework 4.5.2 with the latest service packs.

Software

Microsoft SharePoint Server 2016

Microsoft Data Access Components (MDAC) only
Microsoft SQL Server 2012 (Enterprise / Standard / Developer / Express edition) (or) Microsoft SQL Server 2008 (Enterprise / Standard / Developer / Express edition)  or Microsoft SQL Server 2005 (Enterprise / Standard / Developer / Express edition) running in local / remote computer with latest Service Pack.
 

SharePoint 2013 farms

Processor

Intel Pentium Processor

Operating System

Windows Server 2012 (or) Windows Server 2008 R2 with .NET Framework 4.5 with the latest service packs.

Software

Microsoft SharePoint Server 2013 (or) Microsoft SharePoint Foundation 2013

Microsoft Data Access Components (MDAC) only
Microsoft SQL Server 2012 (Enterprise / Standard / Developer / Express edition) (or) Microsoft SQL Server 2008 (Enterprise / Standard / Developer / Express edition)  or Microsoft SQL Server 2005 (Enterprise / Standard / Developer / Express edition) running in local / remote computer with latest Service Pack.
 

SharePoint 2010 farms

Processor

Intel Pentium Processor

Operating System

Windows Server 2008 with .NET Framework 3.5 with the latest service packs.

Software

Microsoft SharePoint Server 2010 (or) Microsoft SharePoint Foundation 2010 with latest Service Pack.

Microsoft Data Access Components (MDAC) only
Microsoft SQL Server 2012 (Enterprise / Standard / Developer / Express edition) (or) Microsoft SQL Server 2008 (Enterprise / Standard / Developer / Express edition) or Microsoft SQL Server 2005 (Enterprise / Standard / Developer / Express edition) running in local / remote computer with latest Service Pack.
 

SharePoint 2007 farms

Processor Intel Pentium processor
Operating System

Windows Server 2003 (or) Windows Server 2008 with .NET Framework 3.0 or higher with the latest service packs.

Software

Microsoft Office SharePoint Server 2007 (or) Windows SharePoint Services 3.0 with latest Service Pack.

Microsoft Data Access Components (MDAC) only
Microsoft SQL Server 2012 (Enterprise / Standard / Developer / Express edition) (or) Microsoft SQL Server 2008 (Enterprise / Standard / Developer / Express edition) or Microsoft SQL Server 2005 (Enterprise / Standard / Developer / Express edition) running in local / remote computer with latest Service Pack.